muhammara and hummus vulnerable to denial of service by NULL pointer dereference
CVE-2022-25892GHSA-9cv5-4wqv-9w94
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (hummus 1.0.111; muhammara 3.1.1, 2.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9cv5-4wqv-9w94 lists affected ranges: npm muhammara >=0 =3.0.0 =0 <1.0.111 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9cv5-4wqv-9w94 lists affected ranges: npm muhammara >=0 =3.0.0 =0 <1.0.111
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2022-25892: 1.36% estimated exploitation activity in the next 30 days; percentile 71.73 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The package muhammara before 2.6.1, from 3.0.0 and before 3.1.1; all versions of package hummus are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be parsed. Patches It has been patched in 3.1.1 and has been backported to 2.6.1 Hummus has a patch in 1.0.111. Workarounds Do not process files from untrusted sources or update. References https://nvd.nist.gov/vuln/detail/CVE-2022-25892 https://github.com/galkahana/HummusJS/issues/463 https://github.com/julianhille/MuhammaraJS/issues/214 https://github.com/julianhille/MuhammaraJS/commit/1890fb555eaf171db79b73fdc3ea543bbd63c002 https://github.com/julianhille/MuhammaraJS/commit/90b278d09f16062d93a4160ef0a54d449d739c51 https://security.snyk.io/vuln/SNYK-JS-HUMMUS-3091138 https://security.snyk.io/vuln/SNYK-JS-MUHAMMARA-3060320
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9cv5-4wqv-9w94
- Revision 1 · created ·
Published from osv record GHSA-9cv5-4wqv-9w94
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-25892 Advisory: muhammara and hummus vulnerable to denial of service by NULL pointer dereference IDs: CVE-2022-25892, GHSA-9cv5-4wqv-9w94 Record: https://patchnext.com/advisories/cve-2022-25892 (revision 2, source checked 26 Oct 2026, 12:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: hummus 1.0.111; muhammara 3.1.1, 2.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm hummus: affected < 1.0.111; fixed in 1.0.111 - npm muhammara: affected < 2.6.1; >= 3.0.0, < 3.1.1; fixed in 3.1.1, 2.6.1 ## Suggested inspection (read-only) - `npm ls hummus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls muhammara --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on hummus, muhammara. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9cv5-4wqv-9w94 (OSV record GHSA-9cv5-4wqv-9w94 lists affected ranges: npm muhammara >=0 =3.0.0 =0 <1.0.111 (fixed)) - Verified: https://github.com/advisories/GHSA-9cv5-4wqv-9w94 (GitHub-reviewed advisory GHSA-9cv5-4wqv-9w94 lists affected ranges: npm muhammara >=0 =3.0.0 =0 <1.0.111) Commands are suggestions: review each one before running it.
Loading voting…