Medium, CVSS 6.1npmAmendedPublished
Cross-Site Scripting in html-janitor
CVE-2017-0931 · GHSA-hfj4-96f7-6r5g
- Affected
- npm html-janitor < 2.0.3
- Fixed in
- 2.0.3· Vendor fix available
- Issue
- Versions of html-janitor prior to 2.0.2 (all current versions) are vulnerable to cross-site scripting (XSS). This is exploitable if user-controlled data is passed into the modules clean() function. Recommendation No fix is currently available for this vulnerability. It is recommended to use an alternative module for HTML sanitization.
Recommended action: Upgrade to 2.0.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.