Cross-Site Scripting in html-janitor
CVE-2017-0931GHSA-hfj4-96f7-6r5g
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (html-janitor 2.0.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm html-janitor
- Affected
- < 2.0.3
- Fixed in
- 2.0.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hfj4-96f7-6r5g lists affected ranges: npm html-janitor >=0 <2.0.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hfj4-96f7-6r5g lists affected ranges: npm html-janitor >=0 <2.0.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2017-0931: 1.05% estimated exploitation activity in the next 30 days; percentile 64.23 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of html-janitor prior to 2.0.2 (all current versions) are vulnerable to cross-site scripting (XSS). This is exploitable if user-controlled data is passed into the modules clean() function. Recommendation No fix is currently available for this vulnerability. It is recommended to use an alternative module for HTML sanitization.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hfj4-96f7-6r5g
- Revision 1 · created ·
Published from osv record GHSA-hfj4-96f7-6r5g
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-0931 Advisory: Cross-Site Scripting in html-janitor IDs: CVE-2017-0931, GHSA-hfj4-96f7-6r5g Record: https://patchnext.com/advisories/cve-2017-0931 (revision 2, source checked 26 Oct 2026, 12:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: html-janitor 2.0.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm html-janitor: affected < 2.0.3; fixed in 2.0.3 ## Suggested inspection (read-only) - `npm ls html-janitor --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on html-janitor. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hfj4-96f7-6r5g (OSV record GHSA-hfj4-96f7-6r5g lists affected ranges: npm html-janitor >=0 <2.0.3 (fixed)) - Verified: https://github.com/advisories/GHSA-hfj4-96f7-6r5g (GitHub-reviewed advisory GHSA-hfj4-96f7-6r5g lists affected ranges: npm html-janitor >=0 <2.0.3) Commands are suggestions: review each one before running it.
Loading voting…