Medium, CVSS 5.3npmAmendedPublished
Regular Expression Denial of Service in hosted-git-info
CVE-2021-23362 · GHSA-43f8-2h32-f4cj
- Affected
- npm hosted-git-info >= 3.0.0, < 3.0.8; < 2.8.9
- Fixed in
- 3.0.82.8.9· Vendor fix available
- Issue
- The npm package hosted-git-info before 3.0.8 are vulnerable to Regular Expression Denial of Service (ReDoS) via regular expression shortcutMatch in the fromUrl function in index.js. The affected regular expression exhibits polynomial worst-case time complexity
Recommended action: Upgrade to 3.0.8 or 2.8.9 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.
Sources:osv.dev (1)github.com (2)nodejs.org (3)raw.githubusercontent.com (4)Source checked Evidence →