Skip to content

← Actionable
Medium, CVSS 5.3amended

Regular Expression Denial of Service in hosted-git-info

CVE-2021-23362GHSA-43f8-2h32-f4cj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (node 12.22.2; hosted-git-info 3.0.8, 2.8.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • runtime node

    Affected
    >= 12.0.0, < 12.22.2
    Fixed in
    12.22.2
  • npm hosted-git-info

    Affected
    >= 3.0.0, < 3.0.8< 2.8.9
    Fixed in
    3.0.8, 2.8.9

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2021-23362: 3.61% estimated exploitation activity in the next 30 days; percentile 89.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The npm package hosted-git-info before 3.0.8 are vulnerable to Regular Expression Denial of Service (ReDoS) via regular expression shortcutMatch in the fromUrl function in index.js. The affected regular expression exhibits polynomial worst-case time complexity

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from vendor_advisory record nodejs-security-wg:core:82

  2. Revision 2 · amended ·

    Amended from ghsa record GHSA-43f8-2h32-f4cj

  3. Revision 1 · created ·

    Published from osv record GHSA-43f8-2h32-f4cj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-23362

Advisory: Regular Expression Denial of Service in hosted-git-info
IDs: CVE-2021-23362, GHSA-43f8-2h32-f4cj
Record: https://patchnext.com/advisories/cve-2021-23362 (revision 3, source checked 26 Oct 2026, 16:35 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: node 12.22.2; hosted-git-info 3.0.8, 2.8.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- runtime node: affected >= 12.0.0, < 12.22.2; fixed in 12.22.2
- npm hosted-git-info: affected >= 3.0.0, < 3.0.8; < 2.8.9; fixed in 3.0.8, 2.8.9

## Suggested inspection (read-only)
- runtime node: check the installed version with your package manager.
- `npm ls hosted-git-info --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on node, hosted-git-info.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-43f8-2h32-f4cj (OSV record GHSA-43f8-2h32-f4cj lists affected ranges: npm hosted-git-info >=0 =3.0.0 <3.0.8 (fixed))
- Verified: https://github.com/advisories/GHSA-43f8-2h32-f4cj (GitHub-reviewed advisory GHSA-43f8-2h32-f4cj lists affected ranges: npm hosted-git-info >=3.0.0 =0 <2.8.9)
- Verified: https://nodejs.org/dist/index.json (The nodejs.org release index dates the first patched release for CVE-2021-23362 to 2021-07-01.)
- Verified: https://raw.githubusercontent.com/nodejs/security-wg/main/vuln/core/82.json (Node.js security working group core entry 82 lists CVE-2021-23362 affecting node >=12.0.0 <12.22.2)

Commands are suggestions: review each one before running it.

Loading voting…