Skip to content

← Public intelligence

npm package

hackmd-mcp

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.9npmAmendedPublished

    HackMD MCP Server has Server-Side Request Forgery (SSRF) vulnerability

    CVE-2025-59155 · GHSA-g5cg-6c7v-mmpw

    Affected
    • npm hackmd-mcp >= 1.4.0, < 1.5.0
    Fixed in
    1.5.0· Vendor fix available
    Issue
    Impact A Server-Side Request Forgery (SSRF) vulnerability that affects all users running the HackMD MCP server in HTTP mode. Attackers could exploit this vulnerability by passing arbitrary hackmdApiUrl values through HTTP headers (Hackmd-Api-Url) or base64-encoded JSON query parameters. This allows malicious users to: - Redirect API calls to internal network services - Potentially access sensitive internal endpoints - Perform network reconnaissance through the server - Bypass network access controls The vulnerability affects the HTTP transport mode specifically - stdio mode is not impacted as it only accepts requests from stdio. Patches The vulnerability has been patched in version 1.5.0. Users should: 1. Update to the latest version of the HackMD MCP server 2. Set the ALLOWEDHACKMDAPIURLS environment variable to restrict allowed HackMD API endpoints 3. If not set, the server will default to only allowing the official HackMD API URL (https://api.hackmd.io/v1) Example configuration:…

    Recommended action: Upgrade to 1.5.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →