HackMD MCP Server has Server-Side Request Forgery (SSRF) vulnerability
CVE-2025-59155GHSA-g5cg-6c7v-mmpw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (hackmd-mcp 1.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm hackmd-mcp
- Affected
- >= 1.4.0, < 1.5.0
- Fixed in
- 1.5.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-g5cg-6c7v-mmpw lists affected ranges: npm hackmd-mcp >=1.4.0 <1.5.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g5cg-6c7v-mmpw lists affected ranges: npm hackmd-mcp >=1.4.0 <1.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2025-59155: 0.36% estimated exploitation activity in the next 30 days; percentile 29.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A Server-Side Request Forgery (SSRF) vulnerability that affects all users running the HackMD MCP server in HTTP mode. Attackers could exploit this vulnerability by passing arbitrary hackmdApiUrl values through HTTP headers (Hackmd-Api-Url) or base64-encoded JSON query parameters. This allows malicious users to: - Redirect API calls to internal network services - Potentially access sensitive internal endpoints - Perform network reconnaissance through the server - Bypass network access controls The vulnerability affects the HTTP transport mode specifically - stdio mode is not impacted as it only accepts requests from stdio. Patches The vulnerability has been patched in version 1.5.0. Users should: 1. Update to the latest version of the HackMD MCP server 2. Set the ALLOWEDHACKMDAPIURLS environment variable to restrict allowed HackMD API endpoints 3. If not set, the server will default to only allowing the official HackMD API URL (https://api.hackmd.io/v1) Example configuration:…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-g5cg-6c7v-mmpw
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-g5cg-6c7v-mmpw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2025-59155 Advisory: HackMD MCP Server has Server-Side Request Forgery (SSRF) vulnerability IDs: CVE-2025-59155, GHSA-g5cg-6c7v-mmpw Record: https://patchnext.com/advisories/cve-2025-59155 (revision 3, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: hackmd-mcp 1.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm hackmd-mcp: affected >= 1.4.0, < 1.5.0; fixed in 1.5.0 ## Suggested inspection (read-only) - `npm ls hackmd-mcp --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on hackmd-mcp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-g5cg-6c7v-mmpw (OSV record GHSA-g5cg-6c7v-mmpw lists affected ranges: npm hackmd-mcp >=1.4.0 <1.5.0 (fixed)) - Verified: https://github.com/advisories/GHSA-g5cg-6c7v-mmpw (GitHub-reviewed advisory GHSA-g5cg-6c7v-mmpw lists affected ranges: npm hackmd-mcp >=1.4.0 <1.5.0) Commands are suggestions: review each one before running it.
Loading voting…