Skip to content

← Public intelligence

npm package

grunt

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.0npmAmendedPublished

    Race Condition in Grunt

    CVE-2022-1537 · GHSA-rm36-94g8-835r

    Affected
    • npm grunt < 1.5.3
    Fixed in
    1.5.3· Vendor fix available
    Issue
    file.copy operations in GruntJS are vulnerable to a TOCTOU race condition leading to arbitrary file write in GitHub repository gruntjs/grunt prior to 1.5.3. This vulnerability is capable of arbitrary file writes which can lead to local privilege escalation to the GruntJS user if a lower-privileged user has write access to both source and destination directories as the lower-privileged user can create a symlink to the GruntJS user's .bashrc file or replace /etc/shadow file if the GruntJS user is root.

    Recommended action: Upgrade to 1.5.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 5.5npmAmendedPublished

    Path Traversal in Grunt

    CVE-2022-0436 · GHSA-j383-35pm-c5h4

    Affected
    • npm grunt < 1.5.2
    Fixed in
    1.5.2· Vendor fix available
    Issue
    Grunt prior to version 1.5.2 is vulnerable to path traversal.

    Recommended action: Upgrade to 1.5.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. High, CVSS 7.1npmAmendedPublished

    Arbitrary Code Execution in grunt

    CVE-2020-7729 · GHSA-m5pj-vjjf-4m3h

    Affected
    • npm grunt < 1.3.0
    Fixed in
    1.3.0· Vendor fix available
    Issue
    The package grunt before 1.3.0 are vulnerable to Arbitrary Code Execution due to the default usage of the function load() instead of its secure replacement safeLoad() of the package js-yaml inside grunt.file.readYAML.

    Recommended action: Upgrade to 1.3.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →