Skip to content

← Actionable
High, CVSS 7.1amended

Arbitrary Code Execution in grunt

CVE-2020-7729GHSA-m5pj-vjjf-4m3h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (grunt 1.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm grunt

    Affected
    < 1.3.0
    Fixed in
    1.3.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-7729: 2.30% estimated exploitation activity in the next 30 days; percentile 83.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The package grunt before 1.3.0 are vulnerable to Arbitrary Code Execution due to the default usage of the function load() instead of its secure replacement safeLoad() of the package js-yaml inside grunt.file.readYAML.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-m5pj-vjjf-4m3h

  2. Revision 1 · created ·

    Published from osv record GHSA-m5pj-vjjf-4m3h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-7729

Advisory: Arbitrary Code Execution in grunt
IDs: CVE-2020-7729, GHSA-m5pj-vjjf-4m3h
Record: https://patchnext.com/advisories/cve-2020-7729 (revision 2, source checked 26 Oct 2026, 12:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: grunt 1.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm grunt: affected < 1.3.0; fixed in 1.3.0

## Suggested inspection (read-only)
- `npm ls grunt --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on grunt.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m5pj-vjjf-4m3h (OSV record GHSA-m5pj-vjjf-4m3h lists affected ranges: npm grunt >=0 <1.3.0 (fixed))
- Verified: https://github.com/advisories/GHSA-m5pj-vjjf-4m3h (GitHub-reviewed advisory GHSA-m5pj-vjjf-4m3h lists affected ranges: npm grunt >=0 <1.3.0)

Commands are suggestions: review each one before running it.

Loading voting…