Medium, CVSS 5.3npmAmendedPublished
graphql Uncontrolled Resource Consumption vulnerability
CVE-2023-26144 · GHSA-9pv7-vfvm-6vr7
- Affected
- npm graphql >= 16.3.0, < 16.8.1
- Fixed in
- 16.8.1· Vendor fix available
- Issue
- Versions of the package graphql from 16.3.0 and before 16.8.1 are vulnerable to Denial of Service (DoS) due to insufficient checks in the OverlappingFieldsCanBeMergedRule.ts file when parsing large queries. This vulnerability allows an attacker to degrade system performance. Note: It was not proven that this vulnerability can crash the process.
Recommended action: Upgrade to 16.8.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.