graphql Uncontrolled Resource Consumption vulnerability
CVE-2023-26144GHSA-9pv7-vfvm-6vr7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (graphql 16.8.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm graphql
- Affected
- >= 16.3.0, < 16.8.1
- Fixed in
- 16.8.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9pv7-vfvm-6vr7 lists affected ranges: npm graphql >=16.3.0 <16.8.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9pv7-vfvm-6vr7 lists affected ranges: npm graphql >=16.3.0 <16.8.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2023-26144: 1.45% estimated exploitation activity in the next 30 days; percentile 73.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of the package graphql from 16.3.0 and before 16.8.1 are vulnerable to Denial of Service (DoS) due to insufficient checks in the OverlappingFieldsCanBeMergedRule.ts file when parsing large queries. This vulnerability allows an attacker to degrade system performance. Note: It was not proven that this vulnerability can crash the process.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9pv7-vfvm-6vr7
- Revision 1 · created ·
Published from osv record GHSA-9pv7-vfvm-6vr7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-26144 Advisory: graphql Uncontrolled Resource Consumption vulnerability IDs: CVE-2023-26144, GHSA-9pv7-vfvm-6vr7 Record: https://patchnext.com/advisories/cve-2023-26144 (revision 2, source checked 26 Oct 2026, 12:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: graphql 16.8.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm graphql: affected >= 16.3.0, < 16.8.1; fixed in 16.8.1 ## Suggested inspection (read-only) - `npm ls graphql --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on graphql. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9pv7-vfvm-6vr7 (OSV record GHSA-9pv7-vfvm-6vr7 lists affected ranges: npm graphql >=16.3.0 <16.8.1 (fixed)) - Verified: https://github.com/advisories/GHSA-9pv7-vfvm-6vr7 (GitHub-reviewed advisory GHSA-9pv7-vfvm-6vr7 lists affected ranges: npm graphql >=16.3.0 <16.8.1) Commands are suggestions: review each one before running it.
Loading voting…