High, CVSS 7.5npmAmendedPublished
Basic-auth app bundle credential exposure in gatsby-source-wordpress
CVE-2021-32770 · GHSA-rqjw-p5vr-c695
- Affected
- npm gatsby-source-wordpress < 4.0.8; >= 5.0.0, < 5.9.2
- Fixed in
- 4.0.85.9.2· Vendor fix available
- Issue
- Impact The gatsby-source-wordpress plugin prior to versions 4.0.8 and 5.9.2 leaks .htaccess HTTP Basic Authentication variables into the app.js bundle during build-time. Users who are not initializing basic authentication credentials in the gatsby-config.js are not affected. Example affected gatsby-config.js: Patches A patch has been introduced in gatsby-source-wordpress@4.0.8 and gatsby-source-wordpress@5.9.2 which mitigates the issue by filtering all variables specified in the auth: { } section. Users that depend on this functionality are advised to upgrade to the latest release of gatsby-source-wordpress, run gatsby clean followed by a gatsby build. Workarounds There is no known workaround at this time, other than manually editing the app.js file post-build. For more information Email us at security@gatsbyjs.com
Recommended action: Upgrade to 5.9.2 or 4.0.8 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.