Skip to content

← Actionable
High, CVSS 7.5amended

Basic-auth app bundle credential exposure in gatsby-source-wordpress

CVE-2021-32770GHSA-rqjw-p5vr-c695

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gatsby-source-wordpress 5.9.2, 4.0.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2021-32770: 1.41% estimated exploitation activity in the next 30 days; percentile 72.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The gatsby-source-wordpress plugin prior to versions 4.0.8 and 5.9.2 leaks .htaccess HTTP Basic Authentication variables into the app.js bundle during build-time. Users who are not initializing basic authentication credentials in the gatsby-config.js are not affected. Example affected gatsby-config.js: Patches A patch has been introduced in gatsby-source-wordpress@4.0.8 and gatsby-source-wordpress@5.9.2 which mitigates the issue by filtering all variables specified in the auth: { } section. Users that depend on this functionality are advised to upgrade to the latest release of gatsby-source-wordpress, run gatsby clean followed by a gatsby build. Workarounds There is no known workaround at this time, other than manually editing the app.js file post-build. For more information Email us at security@gatsbyjs.com

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-rqjw-p5vr-c695

  2. Revision 1 · created ·

    Published from osv record GHSA-rqjw-p5vr-c695

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2021-32770

Advisory: Basic-auth app bundle credential exposure in gatsby-source-wordpress
IDs: CVE-2021-32770, GHSA-rqjw-p5vr-c695
Record: https://patchnext.com/advisories/cve-2021-32770 (revision 2, source checked 26 Oct 2026, 12:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gatsby-source-wordpress 5.9.2, 4.0.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm gatsby-source-wordpress: affected < 4.0.8; >= 5.0.0, < 5.9.2; fixed in 4.0.8, 5.9.2

## Suggested inspection (read-only)
- `npm ls gatsby-source-wordpress --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gatsby-source-wordpress.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-rqjw-p5vr-c695 (OSV record GHSA-rqjw-p5vr-c695 lists affected ranges: npm gatsby-source-wordpress >=0 =5.0.0 <5.9.2 (fixed))
- Verified: https://github.com/advisories/GHSA-rqjw-p5vr-c695 (GitHub-reviewed advisory GHSA-rqjw-p5vr-c695 lists affected ranges: npm gatsby-source-wordpress >=0 =5.0.0 <5.9.2)

Commands are suggestions: review each one before running it.

Loading voting…