Skip to content

← Public intelligence

npm package

gatsby

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 4.3npmAmendedPublished

    Gatsby develop server has Local File Inclusion vulnerability

    CVE-2023-34238 · GHSA-c6f8-8r25-c4gc

    Affected
    • npm gatsby <= 4.25.6; >= 5.0.0, <= 5.9.0
    Fixed in
    5.9.14.25.7· Vendor fix available
    Issue
    Impact The Gatsby framework prior to versions 4.25.7 and 5.9.1 contain a Local File Inclusion vulnerability in the file-code-frame and original-stack-frame paths, exposed when running the Gatsby develop server (gatsby develop). The following steps can be used to reproduce the vulnerability: It should be noted that by default gatsby develop is only accessible via the localhost 127.0.0.1, and one would need to intentionally expose the server to other interfaces to exploit this vulnerability by using server options such as --host 0.0.0.0, -H 0.0.0.0, or the GATSBYHOST=0.0.0.0 environment variable. Patches A patch has been introduced in gatsby@5.9.1 and gatsby@4.25.7 which mitigates the issue. Workarounds As stated above, by default gatsby develop is only exposed to the localhost 127.0.0.1. For those using the develop server in the default configuration no risk is posed. If other ranges are required, preventing the develop server from being exposed to untrusted interfaces or IP address…

    Recommended action: Upgrade to 5.9.1 or 4.25.7 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →