Gatsby develop server has Local File Inclusion vulnerability
CVE-2023-34238GHSA-c6f8-8r25-c4gc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gatsby 5.9.1, 4.25.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm gatsby
- Affected
- <= 4.25.6>= 5.0.0, <= 5.9.0
- Fixed in
- 5.9.1, 4.25.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-c6f8-8r25-c4gc lists affected ranges: npm gatsby >=0 =5.0.0 <5.9.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c6f8-8r25-c4gc lists affected ranges: npm gatsby >=0 =5.0.0 <=5.9.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2023-34238: 0.91% estimated exploitation activity in the next 30 days; percentile 60.02 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The Gatsby framework prior to versions 4.25.7 and 5.9.1 contain a Local File Inclusion vulnerability in the file-code-frame and original-stack-frame paths, exposed when running the Gatsby develop server (gatsby develop). The following steps can be used to reproduce the vulnerability: It should be noted that by default gatsby develop is only accessible via the localhost 127.0.0.1, and one would need to intentionally expose the server to other interfaces to exploit this vulnerability by using server options such as --host 0.0.0.0, -H 0.0.0.0, or the GATSBYHOST=0.0.0.0 environment variable. Patches A patch has been introduced in gatsby@5.9.1 and gatsby@4.25.7 which mitigates the issue. Workarounds As stated above, by default gatsby develop is only exposed to the localhost 127.0.0.1. For those using the develop server in the default configuration no risk is posed. If other ranges are required, preventing the develop server from being exposed to untrusted interfaces or IP address…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-c6f8-8r25-c4gc
- Revision 1 · created ·
Published from osv record GHSA-c6f8-8r25-c4gc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-34238 Advisory: Gatsby develop server has Local File Inclusion vulnerability IDs: CVE-2023-34238, GHSA-c6f8-8r25-c4gc Record: https://patchnext.com/advisories/cve-2023-34238 (revision 2, source checked 26 Oct 2026, 12:29 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: gatsby 5.9.1, 4.25.7. A vendor fix does not mean a deployment is fixed. ## Affected components - npm gatsby: affected <= 4.25.6; >= 5.0.0, <= 5.9.0; fixed in 5.9.1, 4.25.7 ## Suggested inspection (read-only) - `npm ls gatsby --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gatsby. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-c6f8-8r25-c4gc (OSV record GHSA-c6f8-8r25-c4gc lists affected ranges: npm gatsby >=0 =5.0.0 <5.9.1 (fixed)) - Verified: https://github.com/advisories/GHSA-c6f8-8r25-c4gc (GitHub-reviewed advisory GHSA-c6f8-8r25-c4gc lists affected ranges: npm gatsby >=0 =5.0.0 <=5.9.0) Commands are suggestions: review each one before running it.
Loading voting…