High, CVSS 7.3npmAmendedPublished
fury-adapter-swagger allows arbitrary file read from system
CVE-2016-1000249 · GHSA-2r7f-4h2c-5x73
- Affected
- npm fury-adapter-swagger >= 0.2.0, < 0.9.7
- Fixed in
- 0.9.7· Vendor fix available
- Issue
- fury-adapter-swagger from version 0.2.0 until version 0.9.7 has a weakness that allows an attacker to read arbitrary files off of the system. This can be used to read sensitive data, or to cause a denial of service condition by attempting to read something like /dev/zero. Proof of Concept: Recommendation Upgrade to version 0.9.7 or later.
Recommended action: Upgrade to 0.9.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.