fury-adapter-swagger allows arbitrary file read from system
CVE-2016-1000249GHSA-2r7f-4h2c-5x73
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (fury-adapter-swagger 0.9.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 0.2.0, < 0.9.7
- Fixed in
- 0.9.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-2r7f-4h2c-5x73 lists affected ranges: npm fury-adapter-swagger >=0.2.0 <0.9.7 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2r7f-4h2c-5x73 lists affected ranges: npm fury-adapter-swagger >=0.2.0 <0.9.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
fury-adapter-swagger from version 0.2.0 until version 0.9.7 has a weakness that allows an attacker to read arbitrary files off of the system. This can be used to read sensitive data, or to cause a denial of service condition by attempting to read something like /dev/zero. Proof of Concept: Recommendation Upgrade to version 0.9.7 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-2r7f-4h2c-5x73
- Revision 1 · created ·
Published from osv record GHSA-2r7f-4h2c-5x73
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-1000249 Advisory: fury-adapter-swagger allows arbitrary file read from system IDs: CVE-2016-1000249, GHSA-2r7f-4h2c-5x73 Record: https://patchnext.com/advisories/cve-2016-1000249 (revision 2, source checked 26 Oct 2026, 12:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: fury-adapter-swagger 0.9.7. A vendor fix does not mean a deployment is fixed. ## Affected components - npm fury-adapter-swagger: affected >= 0.2.0, < 0.9.7; fixed in 0.9.7 ## Suggested inspection (read-only) - `npm ls fury-adapter-swagger --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on fury-adapter-swagger. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-2r7f-4h2c-5x73 (OSV record GHSA-2r7f-4h2c-5x73 lists affected ranges: npm fury-adapter-swagger >=0.2.0 <0.9.7 (fixed)) - Verified: https://github.com/advisories/GHSA-2r7f-4h2c-5x73 (GitHub-reviewed advisory GHSA-2r7f-4h2c-5x73 lists affected ranges: npm fury-adapter-swagger >=0.2.0 <0.9.7) Commands are suggestions: review each one before running it.
Loading voting…