Skip to content

← Public intelligence

npm package

froala-editor

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 5.4npmAmendedPublished

    Froala Editor Cross-site Scripting vulnerability

    CVE-2023-41592 · GHSA-hvpq-7vcc-5hj5

    Affected
    • npm froala-editor >= 4.0.1, <= 4.1.3
    Fixed in
    4.1.4· Vendor fix available
    Issue
    Froala Editor v4.0.1 to v4.1.1 was discovered to contain a cross-site scripting (XSS) vulnerability.

    Recommended action: Upgrade to 4.1.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 6.1npmAmendedPublished

    DOM-based cross-site scripting in Froala Editor

    CVE-2019-19935 · GHSA-h236-g5gh-vq6c

    Affected
    • npm froala-editor < 3.2.3
    Fixed in
    3.2.3· Vendor fix available
    Issue
    Froala WYSIWYG HTML Editor is a lightweight WYSIWYG HTML Editor written in JavaScript that enables rich text editing capabilities for web applications. A DOM-based cross-site scripting (XSS) vulnerability exists in versions before 3.2.3 because HTML code in the editor is not correctly sanitized when inserted into the DOM. This allows an attacker that can control the editor content to execute arbitrary JavaScript in the context of the victim’s session.

    Recommended action: Upgrade to 3.2.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Medium, CVSS 6.1npmAmendedPublished

    Cross site scripting in froala-editor

    CVE-2020-22864 · GHSA-97x5-cc53-cv4v

    Affected
    • npm froala-editor <= 4.0.6
    Fixed in
    4.0.11· Vendor fix available
    Issue
    A cross site scripting (XSS) vulnerability in the Insert Video function of Froala WYSIWYG Editor allows attackers to execute arbitrary web scripts or HTML.

    Recommended action: Upgrade to 4.0.11 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →