Froala Editor Cross-site Scripting vulnerability
CVE-2023-41592GHSA-hvpq-7vcc-5hj5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (froala/wysiwyg-editor 4.1.4; froala-editor 4.1.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist froala/wysiwyg-editor
- Affected
- >= 4.0.1, <= 4.1.3
- Fixed in
- 4.1.4
npm froala-editor
- Affected
- >= 4.0.1, <= 4.1.3
- Fixed in
- 4.1.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-hvpq-7vcc-5hj5 lists affected ranges: Packagist froala/wysiwyg-editor >=4.0.1 =4.0.1 <4.1.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hvpq-7vcc-5hj5 lists affected ranges: Packagist froala/wysiwyg-editor >=4.0.1 =4.0.1 <=4.1.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2023-41592: 1.04% estimated exploitation activity in the next 30 days; percentile 64.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Froala Editor v4.0.1 to v4.1.1 was discovered to contain a cross-site scripting (XSS) vulnerability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-hvpq-7vcc-5hj5
- Revision 1 · created ·
Published from osv record GHSA-hvpq-7vcc-5hj5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2023-41592 Advisory: Froala Editor Cross-site Scripting vulnerability IDs: CVE-2023-41592, GHSA-hvpq-7vcc-5hj5 Record: https://patchnext.com/advisories/cve-2023-41592 (revision 2, source checked 26 Oct 2026, 12:36 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: froala/wysiwyg-editor 4.1.4; froala-editor 4.1.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist froala/wysiwyg-editor: affected >= 4.0.1, <= 4.1.3; fixed in 4.1.4 - npm froala-editor: affected >= 4.0.1, <= 4.1.3; fixed in 4.1.4 ## Suggested inspection (read-only) - Packagist froala/wysiwyg-editor: check the installed version with your package manager. - `npm ls froala-editor --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on froala/wysiwyg-editor, froala-editor. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-hvpq-7vcc-5hj5 (OSV record GHSA-hvpq-7vcc-5hj5 lists affected ranges: Packagist froala/wysiwyg-editor >=4.0.1 =4.0.1 <4.1.4 (fixed)) - Verified: https://github.com/advisories/GHSA-hvpq-7vcc-5hj5 (GitHub-reviewed advisory GHSA-hvpq-7vcc-5hj5 lists affected ranges: Packagist froala/wysiwyg-editor >=4.0.1 =4.0.1 <=4.1.3) Commands are suggestions: review each one before running it.
Loading voting…