Medium, CVSS 4.2npmAmendedPublished
Insecure Defaults Leads to Potential MITM in ezseed-transmission
CVE-2016-1000224 · GHSA-p788-rj37-357w
- Affected
- npm ezseed-transmission >= 0.0.10, <= 0.0.14
- Fixed in
- 0.0.15· Vendor fix available
- Issue
- Affected versions of ezseed-transmission download and run a script over an HTTP connection. An attacker in a privileged network position could launch a Man-in-the-Middle attack and intercept the script, replacing it with malicious code, completely compromising the system running ezseed-transmission. Recommendation Update to version 0.0.15 or later.
Recommended action: Upgrade to 0.0.15 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.