Insecure Defaults Leads to Potential MITM in ezseed-transmission
CVE-2016-1000224GHSA-p788-rj37-357w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ezseed-transmission 0.0.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 0.0.10, <= 0.0.14
- Fixed in
- 0.0.15
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p788-rj37-357w lists affected ranges: npm ezseed-transmission >=0.0.10 <0.0.15 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p788-rj37-357w lists affected ranges: npm ezseed-transmission >=0.0.10 <=0.0.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.2 · CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Affected versions of ezseed-transmission download and run a script over an HTTP connection. An attacker in a privileged network position could launch a Man-in-the-Middle attack and intercept the script, replacing it with malicious code, completely compromising the system running ezseed-transmission. Recommendation Update to version 0.0.15 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-p788-rj37-357w
- Revision 1 · created ·
Published from osv record GHSA-p788-rj37-357w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2016-1000224 Advisory: Insecure Defaults Leads to Potential MITM in ezseed-transmission IDs: CVE-2016-1000224, GHSA-p788-rj37-357w Record: https://patchnext.com/advisories/cve-2016-1000224 (revision 2, source checked 26 Oct 2026, 12:08 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ezseed-transmission 0.0.15. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ezseed-transmission: affected >= 0.0.10, <= 0.0.14; fixed in 0.0.15 ## Suggested inspection (read-only) - `npm ls ezseed-transmission --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ezseed-transmission. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p788-rj37-357w (OSV record GHSA-p788-rj37-357w lists affected ranges: npm ezseed-transmission >=0.0.10 <0.0.15 (fixed)) - Verified: https://github.com/advisories/GHSA-p788-rj37-357w (GitHub-reviewed advisory GHSA-p788-rj37-357w lists affected ranges: npm ezseed-transmission >=0.0.10 <=0.0.14) Commands are suggestions: review each one before running it.
Loading voting…