Skip to content

← Public intelligence

npm package

express-jwt

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.7npmAmendedPublished

    Authorization bypass in express-jwt

    CVE-2020-15084 · GHSA-6g6m-m6h5-w9gf

    Affected
    • npm express-jwt <= 5.3.3
    Fixed in
    6.0.0· Vendor fix available
    Issue
    Versions before and including 5.3.3, we are not enforcing the algorithms entry to be specified in the configuration. When algorithms is not specified in the configuration, with the combination of jwks-rsa, it may lead to authorization bypass. Am I affected? You are affected by this vulnerability if all of the following conditions apply: You are using express-jwt AND You do not have algorithms configured in your express-jwt configuration. AND You are using libraries such as jwks-rsa as the secret. How to fix that? Specify algorithms in the express-jwt configuration. The following is an example of a proper configuration Will this update impact my users? The fix provided in patch will not affect your users if you specified the algorithms allowed. The patch now makes algorithms a required configuration. Credit IST Group

    Recommended action: Upgrade to 6.0.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →