Authorization bypass in express-jwt
CVE-2020-15084GHSA-6g6m-m6h5-w9gf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (express-jwt 6.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm express-jwt
- Affected
- <= 5.3.3
- Fixed in
- 6.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6g6m-m6h5-w9gf lists affected ranges: npm express-jwt >=0 <6.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6g6m-m6h5-w9gf lists affected ranges: npm express-jwt >=0 <=5.3.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.7 · CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N
- EPSS
- CVE-2020-15084: 1.22% estimated exploitation activity in the next 30 days; percentile 68.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Overview Versions before and including 5.3.3, we are not enforcing the algorithms entry to be specified in the configuration. When algorithms is not specified in the configuration, with the combination of jwks-rsa, it may lead to authorization bypass. Am I affected? You are affected by this vulnerability if all of the following conditions apply: You are using express-jwt AND You do not have algorithms configured in your express-jwt configuration. AND You are using libraries such as jwks-rsa as the secret. How to fix that? Specify algorithms in the express-jwt configuration. The following is an example of a proper configuration Will this update impact my users? The fix provided in patch will not affect your users if you specified the algorithms allowed. The patch now makes algorithms a required configuration. Credit IST Group
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-6g6m-m6h5-w9gf
- Revision 1 · created ·
Published from osv record GHSA-6g6m-m6h5-w9gf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-15084 Advisory: Authorization bypass in express-jwt IDs: CVE-2020-15084, GHSA-6g6m-m6h5-w9gf Record: https://patchnext.com/advisories/cve-2020-15084 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: express-jwt 6.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm express-jwt: affected <= 5.3.3; fixed in 6.0.0 ## Suggested inspection (read-only) - `npm ls express-jwt --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on express-jwt. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6g6m-m6h5-w9gf (OSV record GHSA-6g6m-m6h5-w9gf lists affected ranges: npm express-jwt >=0 <6.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-6g6m-m6h5-w9gf (GitHub-reviewed advisory GHSA-6g6m-m6h5-w9gf lists affected ranges: npm express-jwt >=0 <=5.3.3) Commands are suggestions: review each one before running it.
Loading voting…