Skip to content

← Public intelligence

npm package

express-cart

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

6 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.8npmAmendedPublished

    express-cart allows any user to create an admin user

    CVE-2018-12457 · GHSA-hr89-w7p6-pjmq

    Affected
    • npm express-cart < 1.1.6
    Fixed in
    1.1.6· Vendor fix available
    Issue
    Express-Cart before 1.1.6 allows remote attackers to create an admin user via an /admin/setup Referer header.

    Recommended action: Upgrade to 1.1.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 8.8npmAmendedPublished

    express-cart unrestricted file upload vulnerability

    CVE-2018-3758 · GHSA-4w62-cq5r-5mmq

    Affected
    • npm express-cart < 1.1.7
    Fixed in
    1.1.7· Vendor fix available
    Issue
    Unrestricted file upload (RCE) in express-cart module before 1.1.7 allows a privileged user to gain access in the hosting machine.

    Recommended action: Upgrade to 1.1.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. High, CVSS 8.8npmAmendedPublished

    Cross-Site Request Forgery in express-cart

    CVE-2020-22403 · GHSA-h5q8-5697-9p9h

    Affected
    • npm express-cart < 1.1.17
    Fixed in
    1.1.17· Vendor fix available
    Issue
    The express-cart package through 1.1.10 for Node.js allows CSRF.

    Recommended action: Upgrade to 1.1.17 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. UnratednpmAmendedPublished

    NoSQL injection in express-cart

    GHSA-f5cv-xrv9-r8w7

    Affected
    • npm express-cart <= 1.1.7
    Fixed in
    1.1.8· Vendor fix available
    Issue
    Versions of express-cart before 1.1.8 are vulnerable to NoSQL injection. The vulnerability is caused by the lack of user input sanitization in the login handlers. In both cases, the customer login and the admin login, parameters from the JSON body are sent directly into the MongoDB query which allows to insert operators. These operators can be used to extract the value of the field blindly in the same manner of a blind SQL injection. In this case, the $regex operator is used to guess each character of the token from the start. Recommendation Update to version 1.1.8 or later.

    Recommended action: Upgrade to 1.1.8 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  5. UnratednpmAmendedPublished

    Path Traversal in express-cart

    GHSA-8h8v-6qqm-fwpq

    Affected
    • npm express-cart <= 1.1.5
    Fixed in
    1.1.7· Vendor fix available
    Issue
    Versions of express-cart before 1.1.7 are vulnerable to Path Traversal. Recommendation Update to version 1.1.7 or later.

    Recommended action: Upgrade to 1.1.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  6. High, CVSS 8.8npmAmendedPublished

    Authentication Bypass by Spoofing in express-cart

    CVE-2018-16483 · GHSA-wj36-v8j4-pc7c

    Affected
    • npm express-cart < 1.1.6
    Fixed in
    1.1.6· Vendor fix available
    Issue
    A deficiency in the access control in module express-cart <=1.1.5 allows unprivileged users to add new users to the application as administrators.

    Recommended action: Upgrade to 1.1.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →