Skip to content

← Actionable
High, CVSS 8.8amended

express-cart allows any user to create an admin user

CVE-2018-12457GHSA-hr89-w7p6-pjmq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (express-cart 1.1.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2018-12457: 1.89% estimated exploitation activity in the next 30 days; percentile 79.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Express-Cart before 1.1.6 allows remote attackers to create an admin user via an /admin/setup Referer header.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hr89-w7p6-pjmq

  2. Revision 1 · created ·

    Published from osv record GHSA-hr89-w7p6-pjmq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-12457

Advisory: express-cart allows any user to create an admin user
IDs: CVE-2018-12457, GHSA-hr89-w7p6-pjmq
Record: https://patchnext.com/advisories/cve-2018-12457 (revision 2, source checked 26 Oct 2026, 12:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: express-cart 1.1.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm express-cart: affected < 1.1.6; fixed in 1.1.6

## Suggested inspection (read-only)
- `npm ls express-cart --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on express-cart.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hr89-w7p6-pjmq (OSV record GHSA-hr89-w7p6-pjmq lists affected ranges: npm express-cart >=0 <1.1.6 (fixed))
- Verified: https://github.com/advisories/GHSA-hr89-w7p6-pjmq (GitHub-reviewed advisory GHSA-hr89-w7p6-pjmq lists affected ranges: npm express-cart >=0 <1.1.6)

Commands are suggestions: review each one before running it.

Loading voting…