Medium, CVSS 6.1npmAmendedPublished
element-plus vulnerable to cross-site scripting (XSS) via el-table-column
CVE-2022-27103 · GHSA-rjvg-8v36-xv9r
- Affected
- npm element-plus < 2.0.6
- Fixed in
- 2.0.6· Vendor fix available
- Issue
- element-plus below 2.0.5 is vulnerable to Cross Site Scripting (XSS) when attribute show-tooltips-overflow of el-table-column is true. The mouseover action will make the text of this column render as html.
Recommended action: Upgrade to 2.0.6 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.