element-plus vulnerable to cross-site scripting (XSS) via el-table-column
CVE-2022-27103GHSA-rjvg-8v36-xv9r
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (element-plus 2.0.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm element-plus
- Affected
- < 2.0.6
- Fixed in
- 2.0.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rjvg-8v36-xv9r lists affected ranges: npm element-plus >=0 <2.0.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rjvg-8v36-xv9r lists affected ranges: npm element-plus >=0 <2.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2022-27103: 0.89% estimated exploitation activity in the next 30 days; percentile 59.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
element-plus below 2.0.5 is vulnerable to Cross Site Scripting (XSS) when attribute show-tooltips-overflow of el-table-column is true. The mouseover action will make the text of this column render as html.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rjvg-8v36-xv9r
- Revision 1 · created ·
Published from osv record GHSA-rjvg-8v36-xv9r
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2022-27103 Advisory: element-plus vulnerable to cross-site scripting (XSS) via el-table-column IDs: CVE-2022-27103, GHSA-rjvg-8v36-xv9r Record: https://patchnext.com/advisories/cve-2022-27103 (revision 2, source checked 26 Oct 2026, 12:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: element-plus 2.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm element-plus: affected < 2.0.6; fixed in 2.0.6 ## Suggested inspection (read-only) - `npm ls element-plus --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on element-plus. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rjvg-8v36-xv9r (OSV record GHSA-rjvg-8v36-xv9r lists affected ranges: npm element-plus >=0 <2.0.6 (fixed)) - Verified: https://github.com/advisories/GHSA-rjvg-8v36-xv9r (GitHub-reviewed advisory GHSA-rjvg-8v36-xv9r lists affected ranges: npm element-plus >=0 <2.0.6) Commands are suggestions: review each one before running it.
Loading voting…