Skip to content

← Public intelligence

npm package

ejs

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

5 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.9npmAmendedPublished

    ejs lacks certain pollution protection

    CVE-2024-33883 · GHSA-ghr5-ch3p-vcr6

    Affected
    • npm ejs < 3.1.10
    Fixed in
    3.1.10· Vendor fix available
    Issue
    The ejs (aka Embedded JavaScript templates) package before 3.1.10 for Node.js lacks certain pollution protection.

    Recommended action: Upgrade to 3.1.10 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.8npmAmendedPublished

    ejs template injection vulnerability

    CVE-2022-29078 · GHSA-phwq-j96m-2c2q

    Affected
    • npm ejs < 3.1.7
    Fixed in
    3.1.7· Vendor fix available
    Issue
    The ejs (aka Embedded JavaScript templates) package 3.1.6 for Node.js allows server-side template injection in settings[view options][outputFunctionName]. This is parsed as an internal option, and overwrites the outputFunctionName option with an arbitrary OS command (which is executed upon template compilation).

    Recommended action: Upgrade to 3.1.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. High, CVSS 7.5npmAmendedPublished

    ejs vulnerable to DoS due to weak input validation

    CVE-2017-1000189 · GHSA-6x77-rpqf-j6mw

    Affected
    • npm ejs < 2.5.5
    Fixed in
    2.5.5· Vendor fix available
    Issue
    nodejs ejs version older than 2.5.5 is vulnerable to a denial-of-service due to weak input validation in ejs.renderFile()

    Recommended action: Upgrade to 2.5.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  4. Critical, CVSS 9.8npmPublished

    ejs is vulnerable to remote code execution due to weak input validation

    CVE-2017-1000228 · GHSA-3w5v-p54c-f74x

    Affected
    • npm ejs < 2.5.5
    Fixed in
    2.5.5· Vendor fix available
    Issue
    nodejs ejs versions older than 2.5.3 is vulnerable to remote code execution due to weak input validation in `ejs.renderFile()` function

    Recommended action: Upgrade to 2.5.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.devSource checked Evidence →
  5. Medium, CVSS 6.1npmAmendedPublished

    mde ejs vulnerable to XSS

    CVE-2017-1000188 · GHSA-hwcf-pp87-7x6p

    Affected
    • npm ejs < 2.5.5
    Fixed in
    2.5.5· Vendor fix available
    Issue
    nodejs ejs version older than 2.5.5 is vulnerable to a Cross-site-scripting in the ejs.renderFile() resulting in code injection

    Recommended action: Upgrade to 2.5.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →