ejs is vulnerable to remote code execution due to weak input validation
CVE-2017-1000228GHSA-3w5v-p54c-f74x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ejs 2.5.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm ejs
- Affected
- < 2.5.5
- Fixed in
- 2.5.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3w5v-p54c-f74x lists affected ranges: npm ejs >=0 <2.5.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2017-1000228: 6.38% estimated exploitation activity in the next 30 days; percentile 93.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
nodejs ejs versions older than 2.5.3 is vulnerable to remote code execution due to weak input validation in `ejs.renderFile()` function
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from osv record GHSA-3w5v-p54c-f74x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-1000228 Advisory: ejs is vulnerable to remote code execution due to weak input validation IDs: CVE-2017-1000228, GHSA-3w5v-p54c-f74x Record: https://patchnext.com/advisories/cve-2017-1000228 (revision 1, source checked 24 Oct 2026, 04:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ejs 2.5.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm ejs: affected < 2.5.5; fixed in 2.5.5 ## Suggested inspection (read-only) - `npm ls ejs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ejs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3w5v-p54c-f74x (OSV record GHSA-3w5v-p54c-f74x lists affected ranges: npm ejs >=0 <2.5.5 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…