Skip to content

← Public intelligence

npm package

dottie

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

2 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. Medium, CVSS 6.3npmAmendedPublished

    dottie is vulnerable to Prototype Pollution bypass via non-first path segments in set() and transform()

    CVE-2026-27837 · GHSA-r5mx-6wc6-7h9w

    Affected
    • npm dottie >= 2.0.4, <= 2.0.6
    Fixed in
    2.0.7· Vendor fix available
    Issue
    dottie versions 2.0.4 through 2.0.6 contain an incomplete fix for CVE-2023-26132. The prototype pollution guard introduced in commit 7d3aee1 only validates the first segment of a dot-separated path, allowing an attacker to bypass the protection by placing proto at any position other than the first. Both dottie.set() and dottie.transform() are affected. Details The existing guard checks only pieces[0] === 'proto'. When a path like 'a.proto.polluted' is used, pieces[0] evaluates to 'a', not 'proto', so the guard is bypassed. Inside the traversal loop, current['proto'] = {} triggers the proto setter, replacing the intermediate object's prototype. The final value is then written onto this new prototype. Important distinction: This vulnerability does NOT pollute the global Object.prototype. It injects properties into a specific object's prototype chain. However, injected properties are invisible to hasOwnProperty() and Object.keys(), which makes them difficult to detect and can…

    Recommended action: Upgrade to 2.0.7 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. High, CVSS 7.5npmAmendedPublished

    dottie vulnerable to Prototype Pollution

    CVE-2023-26132 · GHSA-4gxf-g5gf-22h4

    Affected
    • npm dottie < 2.0.4
    Fixed in
    2.0.4· Vendor fix available
    Issue
    Versions of the package dottie before 2.0.4 are vulnerable to Prototype Pollution due to insufficient checks, via the set() function and the current variable in the /dottie.js file.

    Recommended action: Upgrade to 2.0.4 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →