Skip to content

← Actionable
Medium, CVSS 6.3amended

dottie is vulnerable to Prototype Pollution bypass via non-first path segments in set() and transform()

CVE-2026-27837GHSA-r5mx-6wc6-7h9w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dottie 2.0.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm dottie

    Affected
    >= 2.0.4, <= 2.0.6
    Fixed in
    2.0.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
EPSS
  • CVE-2026-27837: 0.36% estimated exploitation activity in the next 30 days; percentile 30.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary dottie versions 2.0.4 through 2.0.6 contain an incomplete fix for CVE-2023-26132. The prototype pollution guard introduced in commit 7d3aee1 only validates the first segment of a dot-separated path, allowing an attacker to bypass the protection by placing proto at any position other than the first. Both dottie.set() and dottie.transform() are affected. Details The existing guard checks only pieces[0] === 'proto'. When a path like 'a.proto.polluted' is used, pieces[0] evaluates to 'a', not 'proto', so the guard is bypassed. Inside the traversal loop, current['proto'] = {} triggers the proto setter, replacing the intermediate object's prototype. The final value is then written onto this new prototype. Important distinction: This vulnerability does NOT pollute the global Object.prototype. It injects properties into a specific object's prototype chain. However, injected properties are invisible to hasOwnProperty() and Object.keys(), which makes them difficult to detect and can…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-r5mx-6wc6-7h9w

  2. Revision 1 · created ·

    Published from osv record GHSA-r5mx-6wc6-7h9w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-27837

Advisory: dottie is vulnerable to Prototype Pollution bypass via non-first path segments in set() and transform()
IDs: CVE-2026-27837, GHSA-r5mx-6wc6-7h9w
Record: https://patchnext.com/advisories/cve-2026-27837 (revision 2, source checked 26 Oct 2026, 12:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dottie 2.0.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm dottie: affected >= 2.0.4, <= 2.0.6; fixed in 2.0.7

## Suggested inspection (read-only)
- `npm ls dottie --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dottie.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r5mx-6wc6-7h9w (OSV record GHSA-r5mx-6wc6-7h9w lists affected ranges: npm dottie >=2.0.4 <2.0.7 (fixed))
- Verified: https://github.com/advisories/GHSA-r5mx-6wc6-7h9w (GitHub-reviewed advisory GHSA-r5mx-6wc6-7h9w lists affected ranges: npm dottie >=2.0.4 <=2.0.6)

Commands are suggestions: review each one before running it.

Loading voting…