Skip to content

← Public intelligence

npm package

dojox

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 7.7npmAmendedPublished

    Prototype Pollution in Dojox

    CVE-2020-5259 · GHSA-3hw5-q855-g6cw

    Affected
    • npm dojox < 1.11.10; >= 1.12.0, < 1.12.8; >= 1.13.0, < 1.13.7; >= 1.14.0, < 1.14.6; >= 1.15.0, < 1.15.3; >= 1.16.0, < 1.16.2
    Fixed in
    1.11.101.14.61.16.21.12.81.13.71.15.3· Vendor fix available
    Issue
    The Dojox jQuery wrapper jqMix mixin method is vulnerable to Prototype Pollution. Affected Area:

    Recommended action: Upgrade to 1.16.2, 1.15.3, 1.14.6 or 3 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Medium, CVSS 6.1npmAmendedPublished

    XSS in dojox due to insufficient escape in dojox.xmpp.util.xmlEncode

    CVE-2019-10785 · GHSA-pg97-ww7h-5mjr

    Affected
    • npm dojox < 1.11.9; >= 1.12.0, < 1.12.7; >= 1.13.0, < 1.13.6; >= 1.14.0, < 1.14.5; >= 1.15.0, < 1.15.2; >= 1.16.0, <= 1.16.0
    Fixed in
    1.12.71.14.51.11.91.16.11.15.21.13.6· Vendor fix available
    Issue
    Impact What kind of vulnerability is it? Who is impacted? Potential XSS vulnerability for users of dojox/xmpp and dojox/dtl. Patches Has the problem been patched? What versions should users upgrade to? Yes, patches are available for the 1.11 through 1.16 versions. Users should upgrade to one of these versions of Dojo: 1.16.1 1.15.2 1.14.5 1.13.6 1.12.7 1.11.9 Users of Dojo 1.10.x and earlier should review this change and determine if it impacts them, and backport the change as appropriate. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? The change applied in https://github.com/dojo/dojox/pull/315 could get added separately as a patch. For more information If you have any questions or comments about this advisory: Open an issue in dojo/dojox

    Recommended action: Upgrade to 1.16.1, 1.15.2, 1.14.5 or 3 more by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Critical, CVSS 9.8npmAmendedPublished

    dojox vulnerable to unescaped string injection

    CVE-2018-15494 · GHSA-84cm-x2q5-8225

    Affected
    • npm dojox < 1.14.0
    Fixed in
    1.14.0· Vendor fix available
    Issue
    In Dojo Toolkit before 1.14.0, there is unescaped string injection in dojox/Grid/DataGrid.

    Recommended action: Upgrade to 1.14.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →