Skip to content

← Actionable
Medium, CVSS 6.1amended

XSS in dojox due to insufficient escape in dojox.xmpp.util.xmlEncode

CVE-2019-10785GHSA-pg97-ww7h-5mjr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (dojox 1.16.1, 1.15.2, 1.14.5, 1.13.6, 1.12.7, 1.11.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm dojox

    Affected
    < 1.11.9>= 1.12.0, < 1.12.7>= 1.13.0, < 1.13.6>= 1.14.0, < 1.14.5>= 1.15.0, < 1.15.2>= 1.16.0, <= 1.16.0
    Fixed in
    1.12.7, 1.14.5, 1.11.9, 1.16.1, 1.15.2, 1.13.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2019-10785: 1.85% estimated exploitation activity in the next 30 days; percentile 79.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Who is impacted? Potential XSS vulnerability for users of dojox/xmpp and dojox/dtl. Patches Has the problem been patched? What versions should users upgrade to? Yes, patches are available for the 1.11 through 1.16 versions. Users should upgrade to one of these versions of Dojo: 1.16.1 1.15.2 1.14.5 1.13.6 1.12.7 1.11.9 Users of Dojo 1.10.x and earlier should review this change and determine if it impacts them, and backport the change as appropriate. Workarounds Is there a way for users to fix or remediate the vulnerability without upgrading? The change applied in https://github.com/dojo/dojox/pull/315 could get added separately as a patch. For more information If you have any questions or comments about this advisory: Open an issue in dojo/dojox

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pg97-ww7h-5mjr

  2. Revision 1 · created ·

    Published from osv record GHSA-pg97-ww7h-5mjr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2019-10785

Advisory: XSS in dojox due to insufficient escape in dojox.xmpp.util.xmlEncode
IDs: CVE-2019-10785, GHSA-pg97-ww7h-5mjr
Record: https://patchnext.com/advisories/cve-2019-10785 (revision 2, source checked 26 Oct 2026, 12:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: dojox 1.16.1, 1.15.2, 1.14.5, 1.13.6, 1.12.7, 1.11.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm dojox: affected < 1.11.9; >= 1.12.0, < 1.12.7; >= 1.13.0, < 1.13.6; >= 1.14.0, < 1.14.5; >= 1.15.0, < 1.15.2; >= 1.16.0, <= 1.16.0; fixed in 1.12.7, 1.14.5, 1.11.9, 1.16.1, 1.15.2, 1.13.6

## Suggested inspection (read-only)
- `npm ls dojox --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on dojox.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pg97-ww7h-5mjr (OSV record GHSA-pg97-ww7h-5mjr lists affected ranges: npm dojox >=0 =1.12.0 =1.13.0 =1.14.0 =1.15.0 =1.16.0 <1.16.1 (fixed))
- Verified: https://github.com/advisories/GHSA-pg97-ww7h-5mjr (GitHub-reviewed advisory GHSA-pg97-ww7h-5mjr lists affected ranges: npm dojox >=0 =1.12.0 =1.13.0 =1.14.0 =1.15.0 =1.16.0 <=1.16.0)

Commands are suggestions: review each one before running it.

Loading voting…