High, CVSS 8.1npmAmendedPublished
Code Injection in pac-resolver
CVE-2021-23406 · GHSA-9j49-mfvp-vmhm
- Affected
- npm degenerator < 3.0.1
- Fixed in
- 3.0.1· Vendor fix available
- Issue
- This affects the package pac-resolver before 5.0.0. This can occur when used with untrusted input, due to unsafe PAC file handling. NOTE: The fix for this vulnerability is applied in the node-degenerator library, a dependency written by the same maintainer.
Recommended action: Upgrade to 3.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.