Code Injection in pac-resolver
CVE-2021-23406GHSA-9j49-mfvp-vmhm
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pac-resolver 5.0.0; degenerator 3.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm pac-resolver
- Affected
- < 5.0.0
- Fixed in
- 5.0.0
npm degenerator
- Affected
- < 3.0.1
- Fixed in
- 3.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9j49-mfvp-vmhm lists affected ranges: npm pac-resolver >=0 =0 <3.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9j49-mfvp-vmhm lists affected ranges: npm pac-resolver >=0 =0 <3.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-23406: 2.94% estimated exploitation activity in the next 30 days; percentile 87.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This affects the package pac-resolver before 5.0.0. This can occur when used with untrusted input, due to unsafe PAC file handling. NOTE: The fix for this vulnerability is applied in the node-degenerator library, a dependency written by the same maintainer.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-9j49-mfvp-vmhm
- Revision 1 · created ·
Published from osv record GHSA-9j49-mfvp-vmhm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-23406 Advisory: Code Injection in pac-resolver IDs: CVE-2021-23406, GHSA-9j49-mfvp-vmhm Record: https://patchnext.com/advisories/cve-2021-23406 (revision 2, source checked 26 Oct 2026, 12:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pac-resolver 5.0.0; degenerator 3.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm pac-resolver: affected < 5.0.0; fixed in 5.0.0 - npm degenerator: affected < 3.0.1; fixed in 3.0.1 ## Suggested inspection (read-only) - `npm ls pac-resolver --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls degenerator --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pac-resolver, degenerator. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9j49-mfvp-vmhm (OSV record GHSA-9j49-mfvp-vmhm lists affected ranges: npm pac-resolver >=0 =0 <3.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-9j49-mfvp-vmhm (GitHub-reviewed advisory GHSA-9j49-mfvp-vmhm lists affected ranges: npm pac-resolver >=0 =0 <3.0.1) Commands are suggestions: review each one before running it.
Loading voting…