Critical, CVSS 9.8npmAmendedPublished
Prototype Pollution in deep-override
CVE-2021-25941 · GHSA-v659-54cx-g4qr
- Affected
- npm deep-override >= 1.0.0, < 1.0.2
- Fixed in
- 1.0.2· Vendor fix available
- Issue
- Prototype pollution vulnerability in 'deep-override' versions 1.0.0 through 1.0.1 allows an attacker to cause a denial of service and may lead to remote code execution.
Recommended action: Upgrade to 1.0.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.