Prototype Pollution in deep-override
CVE-2021-25941GHSA-v659-54cx-g4qr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (deep-override 1.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm deep-override
- Affected
- >= 1.0.0, < 1.0.2
- Fixed in
- 1.0.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-v659-54cx-g4qr lists affected ranges: npm deep-override >=1.0.0 <1.0.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v659-54cx-g4qr lists affected ranges: npm deep-override >=1.0.0 <1.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2021-25941: 3.34% estimated exploitation activity in the next 30 days; percentile 88.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Prototype pollution vulnerability in 'deep-override' versions 1.0.0 through 1.0.1 allows an attacker to cause a denial of service and may lead to remote code execution.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-v659-54cx-g4qr
- Revision 1 · created ·
Published from osv record GHSA-v659-54cx-g4qr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2021-25941 Advisory: Prototype Pollution in deep-override IDs: CVE-2021-25941, GHSA-v659-54cx-g4qr Record: https://patchnext.com/advisories/cve-2021-25941 (revision 2, source checked 26 Oct 2026, 12:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: deep-override 1.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm deep-override: affected >= 1.0.0, < 1.0.2; fixed in 1.0.2 ## Suggested inspection (read-only) - `npm ls deep-override --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on deep-override. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-v659-54cx-g4qr (OSV record GHSA-v659-54cx-g4qr lists affected ranges: npm deep-override >=1.0.0 <1.0.2 (fixed)) - Verified: https://github.com/advisories/GHSA-v659-54cx-g4qr (GitHub-reviewed advisory GHSA-v659-54cx-g4qr lists affected ranges: npm deep-override >=1.0.0 <1.0.2) Commands are suggestions: review each one before running it.
Loading voting…