Skip to content

← Public intelligence

npm package

dectalk-tts

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

1 actionable advisory, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.2npmAmendedPublished

    dectalk-tts Uses Unencrypted HTTP Request

    CVE-2024-31206 · GHSA-6cf6-8hvr-r68w

    Affected
    • npm dectalk-tts >= 1.0.0, <= 1.0.0
    Fixed in
    1.0.1· Vendor fix available
    Issue
    Impact In dectalk-tts@1.0.0, network requests to the third-party API are sent over HTTP, which is unencrypted. Unencrypted traffic can be easily intercepted and modified by attackers. Anyone who uses the package could be the victim of a man-in-the-middle (MITM) attack. <insTheft</ins Because dectalk-tts is a text-to-speech package, user requests are expected to only contain natural language. The package README warns that user input is sent to a third-party API, so users should not send sensitive information regardless. But if users ignore the warnings and send sensitive information anyway, that information could be stolen by attackers. <insModification</ins Attackers could manipulate requests to the API. However, the worst a modified request could do is return an incorrect audio file or bad request rejection. Attackers could also manipulate responses from the API, returning malicious output to the user. Output is expected to be a wav-encoded buffer, which users will likely save to a…

    Recommended action: Upgrade to 1.0.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →