dectalk-tts Uses Unencrypted HTTP Request
CVE-2024-31206GHSA-6cf6-8hvr-r68w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dectalk-tts 1.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm dectalk-tts
- Affected
- >= 1.0.0, <= 1.0.0
- Fixed in
- 1.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6cf6-8hvr-r68w lists affected ranges: npm dectalk-tts >=1.0.0 <1.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6cf6-8hvr-r68w lists affected ranges: npm dectalk-tts >=1.0.0 <=1.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N
- EPSS
- CVE-2024-31206: 0.33% estimated exploitation activity in the next 30 days; percentile 26.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact In dectalk-tts@1.0.0, network requests to the third-party API are sent over HTTP, which is unencrypted. Unencrypted traffic can be easily intercepted and modified by attackers. Anyone who uses the package could be the victim of a man-in-the-middle (MITM) attack. <insTheft</ins Because dectalk-tts is a text-to-speech package, user requests are expected to only contain natural language. The package README warns that user input is sent to a third-party API, so users should not send sensitive information regardless. But if users ignore the warnings and send sensitive information anyway, that information could be stolen by attackers. <insModification</ins Attackers could manipulate requests to the API. However, the worst a modified request could do is return an incorrect audio file or bad request rejection. Attackers could also manipulate responses from the API, returning malicious output to the user. Output is expected to be a wav-encoded buffer, which users will likely save to a…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-6cf6-8hvr-r68w
- Revision 1 · created ·
Published from osv record GHSA-6cf6-8hvr-r68w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-31206 Advisory: dectalk-tts Uses Unencrypted HTTP Request IDs: CVE-2024-31206, GHSA-6cf6-8hvr-r68w Record: https://patchnext.com/advisories/cve-2024-31206 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dectalk-tts 1.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm dectalk-tts: affected >= 1.0.0, <= 1.0.0; fixed in 1.0.1 ## Suggested inspection (read-only) - `npm ls dectalk-tts --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dectalk-tts. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6cf6-8hvr-r68w (OSV record GHSA-6cf6-8hvr-r68w lists affected ranges: npm dectalk-tts >=1.0.0 <1.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-6cf6-8hvr-r68w (GitHub-reviewed advisory GHSA-6cf6-8hvr-r68w lists affected ranges: npm dectalk-tts >=1.0.0 <=1.0.0) Commands are suggestions: review each one before running it.
Loading voting…