Skip to content

← Public intelligence

npm package

debug

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.8npmAmendedPublished

    debug@4.4.2 contains malware after npm account takeover

    CVE-2025-59144 · GHSA-4x49-vf9v-38px

    Affected
    • npm debug >= 4.4.2, < 4.4.3
    Fixed in
    4.4.3· Vendor fix available
    Issue
    Impact On 8 September 2025, the npm publishing account for `debug` was taken over after a phishing attack. Version `4.4.2` was published, functionally identical to the previous patch version, but with a malware payload added attempting to redirect cryptocurrency transactions to the attacker's own addresses from within browser environments. Local environments, server environments, command line applications, etc. are not affected. If the package was used in a browser context (e.g. a direct ` ` inclusion, or via a bundling tool such as Babel, Rollup, Vite, Next.js, etc.) there is a chance the malware still exists and such bundles will need to be rebuilt. The malware seemingly only targets cryptocurrency transactions and wallets such as MetaMask. See references below for more information on the payload. Patches npm removed the offending package from the registry over the course of the day on 8 September, preventing further downloads from npm proper. On 13 September, the package…

    Recommended action: Upgrade to 4.4.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.devSource checked Evidence →
  2. High, CVSS 7.5npmAmendedPublished

    debug Inefficient Regular Expression Complexity vulnerability

    CVE-2017-20165 · GHSA-9vvw-cc9w-f27h

    Affected
    • npm debug < 2.6.9; >= 3.0.0, < 3.1.0
    Fixed in
    2.6.93.1.0· Vendor fix available
    Issue
    A vulnerability classified as problematic has been found in debug-js debug up to 3.0.x. This affects the function useColors of the file src/node.js. The manipulation of the argument str leads to inefficient regular expression complexity. Upgrading to version 3.1.0 is able to address this issue. The name of the patch is c38a0166c266a679c8de012d4eaccec3f944e685. It is recommended to upgrade the affected component. The identifier VDB-217665 was assigned to this vulnerability. The patch has been backported to the 2.6.x branch in version 2.6.9.

    Recommended action: Upgrade to 3.1.0 or 2.6.9 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. Low, CVSS 3.7npmAmendedPublished

    Regular Expression Denial of Service in debug

    CVE-2017-16137 · GHSA-gxpj-cx7g-858c

    Affected
    • npm debug < 2.6.9; >= 3.0.0, < 3.1.0; >= 3.2.0, < 3.2.7; >= 4.0.0, < 4.3.1
    Fixed in
    2.6.94.3.13.1.03.2.7· Vendor fix available
    Issue
    Affected versions of debug are vulnerable to regular expression denial of service when untrusted user input is passed into the o formatter. As it takes 50,000 characters to block the event loop for 2 seconds, this issue is a low severity issue. This was later re-introduced in version v3.2.0, and then repatched in versions 3.2.7 and 4.3.1. Recommendation Version 2.x.x: Update to version 2.6.9 or later. Version 3.1.x: Update to version 3.1.0 or later. Version 3.2.x: Update to version 3.2.7 or later. Version 4.x.x: Update to version 4.3.1 or later.

    Recommended action: Upgrade to 4.3.1, 3.2.7, 3.1.0 or 2.6.9 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →