Regular Expression Denial of Service in debug
CVE-2017-16137GHSA-gxpj-cx7g-858c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (debug 4.3.1, 3.2.7, 3.1.0, 2.6.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm debug
- Affected
- < 2.6.9>= 3.0.0, < 3.1.0>= 3.2.0, < 3.2.7>= 4.0.0, < 4.3.1
- Fixed in
- 2.6.9, 4.3.1, 3.1.0, 3.2.7
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-gxpj-cx7g-858c lists affected ranges: npm debug >=0 =3.0.0 =3.2.0 =4.0.0 <4.3.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gxpj-cx7g-858c lists affected ranges: npm debug >=0 =3.0.0 =3.2.0 =4.0.0 <4.3.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L
- EPSS
- CVE-2017-16137: 2.83% estimated exploitation activity in the next 30 days; percentile 86.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of debug are vulnerable to regular expression denial of service when untrusted user input is passed into the o formatter. As it takes 50,000 characters to block the event loop for 2 seconds, this issue is a low severity issue. This was later re-introduced in version v3.2.0, and then repatched in versions 3.2.7 and 4.3.1. Recommendation Version 2.x.x: Update to version 2.6.9 or later. Version 3.1.x: Update to version 3.1.0 or later. Version 3.2.x: Update to version 3.2.7 or later. Version 4.x.x: Update to version 4.3.1 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-gxpj-cx7g-858c
- Revision 1 · created ·
Published from osv record GHSA-gxpj-cx7g-858c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2017-16137 Advisory: Regular Expression Denial of Service in debug IDs: CVE-2017-16137, GHSA-gxpj-cx7g-858c Record: https://patchnext.com/advisories/cve-2017-16137 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: debug 4.3.1, 3.2.7, 3.1.0, 2.6.9. A vendor fix does not mean a deployment is fixed. ## Affected components - npm debug: affected < 2.6.9; >= 3.0.0, < 3.1.0; >= 3.2.0, < 3.2.7; >= 4.0.0, < 4.3.1; fixed in 2.6.9, 4.3.1, 3.1.0, 3.2.7 ## Suggested inspection (read-only) - `npm ls debug --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on debug. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-gxpj-cx7g-858c (OSV record GHSA-gxpj-cx7g-858c lists affected ranges: npm debug >=0 =3.0.0 =3.2.0 =4.0.0 <4.3.1 (fixed)) - Verified: https://github.com/advisories/GHSA-gxpj-cx7g-858c (GitHub-reviewed advisory GHSA-gxpj-cx7g-858c lists affected ranges: npm debug >=0 =3.0.0 =3.2.0 =4.0.0 <4.3.1) Commands are suggestions: review each one before running it.
Loading voting…