High, CVSS 7.7npmAmendedPublished
Regular Expression Denial of Service (ReDoS) in cross-spawn
CVE-2024-21538 · GHSA-3xgq-45jj-v275
- Affected
- npm cross-spawn >= 7.0.0, < 7.0.5; < 6.0.6
- Fixed in
- 6.0.67.0.5· Vendor fix available
- Issue
- Versions of the package cross-spawn before 7.0.5 are vulnerable to Regular Expression Denial of Service (ReDoS) due to improper input sanitization. An attacker can increase the CPU usage and crash the program by crafting a very large and well crafted string.
Recommended action: Upgrade to 7.0.5 or 6.0.6 by release line, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.