Regular Expression Denial of Service (ReDoS) in cross-spawn
CVE-2024-21538GHSA-3xgq-45jj-v275
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cross-spawn 7.0.5, 6.0.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm cross-spawn
- Affected
- >= 7.0.0, < 7.0.5< 6.0.6
- Fixed in
- 6.0.6, 7.0.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-3xgq-45jj-v275 lists affected ranges: npm cross-spawn >=7.0.0 =0 <6.0.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-3xgq-45jj-v275 lists affected ranges: npm cross-spawn >=7.0.0 =0 <6.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2024-21538: 0.87% estimated exploitation activity in the next 30 days; percentile 58.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Versions of the package cross-spawn before 7.0.5 are vulnerable to Regular Expression Denial of Service (ReDoS) due to improper input sanitization. An attacker can increase the CPU usage and crash the program by crafting a very large and well crafted string.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-3xgq-45jj-v275
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-3xgq-45jj-v275
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2024-21538 Advisory: Regular Expression Denial of Service (ReDoS) in cross-spawn IDs: CVE-2024-21538, GHSA-3xgq-45jj-v275 Record: https://patchnext.com/advisories/cve-2024-21538 (revision 3, source checked 26 Oct 2026, 12:37 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cross-spawn 7.0.5, 6.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm cross-spawn: affected >= 7.0.0, < 7.0.5; < 6.0.6; fixed in 6.0.6, 7.0.5 ## Suggested inspection (read-only) - `npm ls cross-spawn --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cross-spawn. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-3xgq-45jj-v275 (OSV record GHSA-3xgq-45jj-v275 lists affected ranges: npm cross-spawn >=7.0.0 =0 <6.0.6 (fixed)) - Verified: https://github.com/advisories/GHSA-3xgq-45jj-v275 (GitHub-reviewed advisory GHSA-3xgq-45jj-v275 lists affected ranges: npm cross-spawn >=7.0.0 =0 <6.0.6) Commands are suggestions: review each one before running it.
Loading voting…