Skip to content

← Public intelligence

npm package

codecov

Open actionable advisories and recorded vendor fixes. This public package view has no inventory attached and cannot establish whether your deployment is affected. A vendor fix never resolves your finding; verify your installed version and the source guidance.

Open advisories

3 actionable advisories, newest first. Withdrawn advisories and news are excluded. Coverage is partial.

  1. High, CVSS 8.8npmAmendedPublished

    Improper Neutralization of Special Elements in Output Used by a Downstream Component in Codecov

    CVE-2020-7596 · GHSA-mh2h-6j8q-x246

    Affected
    • npm codecov <= 3.6.1
    Fixed in
    3.6.2· Vendor fix available
    Issue
    Codecov npm module before 3.6.2 allows remote attackers to execute arbitrary commands via the "gcov-args" argument.

    Recommended action: Upgrade to 3.6.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  2. Critical, CVSS 9.3npmAmendedPublished

    Command injection in codecov (npm package)

    CVE-2020-15123 · GHSA-xp63-6vf5-xf3v

    Affected
    • npm codecov < 3.7.1
    Fixed in
    3.7.1· Vendor fix available
    Issue
    Impact The upload method has a command injection vulnerability. Clients of the codecov-node library are unlikely to be aware of this, so they might unwittingly write code that contains a vulnerability. A similar CVE was issued: CVE-2020-7597, but the fix was incomplete. It only blocked &, and command injection is still possible using backticks instead to bypass the sanitizer. We have written a CodeQL query, which automatically detects this vulnerability. You can see the results of the query on the codecov-node project here. Patches This has been patched in version 3.7.1 Workarounds None, however, the attack surface is low in this case. Particularly in the standard use of codecov, where the module is used directly in a build pipeline, not built against as a library in another application that may supply malicious input and perform command injection. References CVE-2020-7597 For more information If you have any questions or comments about this advisory: Contact us via our Security Email

    Recommended action: Upgrade to 3.7.1 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →
  3. High, CVSS 8.8npmAmendedPublished

    codecov NPM module allows remote attackers to execute arbitrary commands

    CVE-2020-7597 · GHSA-5q88-cjfq-g2mh

    Affected
    • npm codecov < 3.6.5
    Fixed in
    3.6.5· Vendor fix available
    Issue
    codecov-node npm module before 3.6.5 allows remote attackers to execute arbitrary commands.The value provided as part of the gcov-root argument is executed by the exec function within lib/codecov.js. This vulnerability exists due to an incomplete fix of CVE-2020-7596.

    Recommended action: Upgrade to 3.6.5 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.

    Sources:osv.dev (1)github.com (2)Source checked Evidence →