Command injection in codecov (npm package)
CVE-2020-15123GHSA-xp63-6vf5-xf3v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (codecov 3.7.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm codecov
- Affected
- < 3.7.1
- Fixed in
- 3.7.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xp63-6vf5-xf3v lists affected ranges: npm codecov >=0 <3.7.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xp63-6vf5-xf3v lists affected ranges: npm codecov >=0 <3.7.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
- EPSS
- CVE-2020-15123: 3.81% estimated exploitation activity in the next 30 days; percentile 90.03 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact The upload method has a command injection vulnerability. Clients of the codecov-node library are unlikely to be aware of this, so they might unwittingly write code that contains a vulnerability. A similar CVE was issued: CVE-2020-7597, but the fix was incomplete. It only blocked &, and command injection is still possible using backticks instead to bypass the sanitizer. We have written a CodeQL query, which automatically detects this vulnerability. You can see the results of the query on the codecov-node project here. Patches This has been patched in version 3.7.1 Workarounds None, however, the attack surface is low in this case. Particularly in the standard use of codecov, where the module is used directly in a build pipeline, not built against as a library in another application that may supply malicious input and perform command injection. References CVE-2020-7597 For more information If you have any questions or comments about this advisory: Contact us via our Security Email
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xp63-6vf5-xf3v
- Revision 1 · created ·
Published from osv record GHSA-xp63-6vf5-xf3v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-15123 Advisory: Command injection in codecov (npm package) IDs: CVE-2020-15123, GHSA-xp63-6vf5-xf3v Record: https://patchnext.com/advisories/cve-2020-15123 (revision 2, source checked 26 Oct 2026, 12:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: codecov 3.7.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm codecov: affected < 3.7.1; fixed in 3.7.1 ## Suggested inspection (read-only) - `npm ls codecov --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on codecov. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xp63-6vf5-xf3v (OSV record GHSA-xp63-6vf5-xf3v lists affected ranges: npm codecov >=0 <3.7.1 (fixed)) - Verified: https://github.com/advisories/GHSA-xp63-6vf5-xf3v (GitHub-reviewed advisory GHSA-xp63-6vf5-xf3v lists affected ranges: npm codecov >=0 <3.7.1) Commands are suggestions: review each one before running it.
Loading voting…