Critical, CVSS 9.3npmAmendedPublished
CleverTap Cordova plugin vulnerable to Cross-site Scripting
CVE-2023-2507 · GHSA-x2ph-qqwm-9cc6
- Affected
- npm clevertap-cordova < 2.7.0
- Fixed in
- 2.7.0· Vendor fix available
- Issue
- CleverTap Cordova Plugin version 2.6.2 allows a remote attacker to execute JavaScript code in any application that is opened via a specially constructed deeplink by an attacker. This is possible because the plugin does not correctly validate the data coming from the deeplinks before using them.
Recommended action: Upgrade to 2.7.0 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.