Skip to content

← Actionable
Critical, CVSS 9.3amended

CleverTap Cordova plugin vulnerable to Cross-site Scripting

CVE-2023-2507GHSA-x2ph-qqwm-9cc6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (clevertap-cordova 2.7.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N
EPSS
  • CVE-2023-2507: 0.85% estimated exploitation activity in the next 30 days; percentile 58.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

CleverTap Cordova Plugin version 2.6.2 allows a remote attacker to execute JavaScript code in any application that is opened via a specially constructed deeplink by an attacker. This is possible because the plugin does not correctly validate the data coming from the deeplinks before using them.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-x2ph-qqwm-9cc6

  2. Revision 1 · created ·

    Published from osv record GHSA-x2ph-qqwm-9cc6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2023-2507

Advisory: CleverTap Cordova plugin vulnerable to Cross-site Scripting
IDs: CVE-2023-2507, GHSA-x2ph-qqwm-9cc6
Record: https://patchnext.com/advisories/cve-2023-2507 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: clevertap-cordova 2.7.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm clevertap-cordova: affected < 2.7.0; fixed in 2.7.0

## Suggested inspection (read-only)
- `npm ls clevertap-cordova --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on clevertap-cordova.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-x2ph-qqwm-9cc6 (OSV record GHSA-x2ph-qqwm-9cc6 lists affected ranges: npm clevertap-cordova >=0 <2.7.0 (fixed))
- Verified: https://github.com/advisories/GHSA-x2ph-qqwm-9cc6 (GitHub-reviewed advisory GHSA-x2ph-qqwm-9cc6 lists affected ranges: npm clevertap-cordova >=0 <2.7.0)

Commands are suggestions: review each one before running it.

Loading voting…