Medium, CVSS 6.1npmAmendedPublished
Enhanced Image plugin for CKEditor is vulnerable to Cross-site scripting (XSS)
CVE-2018-9861 · GHSA-g78h-pf65-46rv
- Affected
- npm ckeditor-dev >= 4.5.10, < 4.9.2
- Fixed in
- 4.9.2· Vendor fix available
- Issue
- The Enhanced Image (aka image2) plugin for CKEditor in versions 4.5.10 through 4.9.1; fixed in 4.9.2, and as used in Drupal 8 before 8.4.7 and 8.5.x before 8.5.2 and other products, is vulnerable to cross-site scripting because it allows remote attackers to inject arbitrary web script through a crafted IMG element.
Recommended action: Upgrade to 4.9.2 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.