Skip to content

← Actionable
Medium, CVSS 6.1amended

Enhanced Image plugin for CKEditor is vulnerable to Cross-site scripting (XSS)

CVE-2018-9861GHSA-g78h-pf65-46rv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/core 8.5.2, 8.4.7; drupal/drupal 8.5.2, 8.4.7; ckeditor-dev 4.9.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist drupal/core

    Affected
    >= 8.0, < 8.4.7>= 8.5.0, < 8.5.2
    Fixed in
    8.5.2, 8.4.7
  • Packagist drupal/drupal

    Affected
    >= 8.0, < 8.4.7>= 8.5, < 8.5.2
    Fixed in
    8.5.2, 8.4.7
  • npm ckeditor-dev

    Affected
    >= 4.5.10, < 4.9.2
    Fixed in
    4.9.2

Sources

  • Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database

    OSV record GHSA-g78h-pf65-46rv lists affected ranges: Packagist drupal/core >=8.5.0 =8.0 =8.0.0-beta10 =8.0.0-beta11 =8.0.0-beta12 =8.0.0-beta13 =8.0.0-beta14 =8.0.0-beta15 =8.0.0-beta16 =8.0.0-beta6 =8.0.0-beta7 =8.0.0-beta8 =8.0.0-beta9 =8.0.0-rc1 =8.0.0-rc2…

    VerifiedObserved Structured OSV record; GitHub-reviewed advisory.

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-g78h-pf65-46rv lists affected ranges: Packagist drupal/core >=8.0 =8.5.0 =4.5.10 =8.0 =8.5 <8.5.2

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2018-9861: 1.72% estimated exploitation activity in the next 30 days; percentile 77.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The Enhanced Image (aka image2) plugin for CKEditor in versions 4.5.10 through 4.9.1; fixed in 4.9.2, and as used in Drupal 8 before 8.4.7 and 8.5.x before 8.5.2 and other products, is vulnerable to cross-site scripting because it allows remote attackers to inject arbitrary web script through a crafted IMG element.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-g78h-pf65-46rv

  2. Revision 1 · created ·

    Published from osv record GHSA-g78h-pf65-46rv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2018-9861

Advisory: Enhanced Image plugin for CKEditor is vulnerable to Cross-site scripting (XSS)
IDs: CVE-2018-9861, GHSA-g78h-pf65-46rv
Record: https://patchnext.com/advisories/cve-2018-9861 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: drupal/core 8.5.2, 8.4.7; drupal/drupal 8.5.2, 8.4.7; ckeditor-dev 4.9.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist drupal/core: affected >= 8.0, < 8.4.7; >= 8.5.0, < 8.5.2; fixed in 8.5.2, 8.4.7
- Packagist drupal/drupal: affected >= 8.0, < 8.4.7; >= 8.5, < 8.5.2; fixed in 8.5.2, 8.4.7
- npm ckeditor-dev: affected >= 4.5.10, < 4.9.2; fixed in 4.9.2

## Suggested inspection (read-only)
- Packagist drupal/core: check the installed version with your package manager.
- Packagist drupal/drupal: check the installed version with your package manager.
- `npm ls ckeditor-dev --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on drupal/core, drupal/drupal, ckeditor-dev.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-g78h-pf65-46rv (OSV record GHSA-g78h-pf65-46rv lists affected ranges: Packagist drupal/core >=8.5.0 =8.0 =8.0.0-beta10 =8.0.0-beta11 =8.0.0-beta12 =8.0.0-beta13 =8.0.0-beta14 =8.0.0-beta15 =8.0.0-beta16 =8.0.0-beta6 =8.0.0-beta7 =8.0.0-beta8 =8.0.0-beta9 =8.0.0-rc1 =8.0.0-rc2…)
- Verified: https://github.com/advisories/GHSA-g78h-pf65-46rv (GitHub-reviewed advisory GHSA-g78h-pf65-46rv lists affected ranges: Packagist drupal/core >=8.0 =8.5.0 =4.5.10 =8.0 =8.5 <8.5.2)

Commands are suggestions: review each one before running it.

Loading voting…