Critical, CVSS 9.0npmAmendedPublished
Prototype Pollution leading to Remote Code Execution in superjson
CVE-2022-23631 · GHSA-5888-ffcr-r425
- Affected
- npm blitz < 0.45.3
- Fixed in
- 0.45.3· Vendor fix available
- Issue
- Impact This is critical vulnerability, as it allows to run arbitrary code on any server using superjson input, including a Blitz.js server, without prior authentication or knowledge. Attackers gain full control over the server so they could steal and manipulate data or attack further systems. The only requirement is that the server implements at least one endpoint which uses superjson during request processing. In the case of Blitz.js, it would be at least one RPC call. Patches This has been patched in superjson 1.8.1 and Blitz.js 0.45.3. If you are unable to upgrade to Blitz.js 0.45.3 in a timely manner, you can instead upgrade only superjson to version 1.8.1 using yarn resolutions are similar. Blitz versions < 0.45.3 are only affected because they used superjson versions < 1.8.1. Workarounds None For more information If you have any questions or comments about this advisory: Open an issue in https://github.com/blitz-js/superjson Email us at b@bayer.ws References…
Recommended action: Upgrade to 0.45.3 or later, then redeploy and verify.A vendor fix does not resolve your finding until you verify it in your own systems.